Remembering old IP address?

Got a problem with Viscosity or need help? Ask here!

la442

Posts: 4
Joined: Sun Dec 09, 2018 2:47 am

Post by la442 » Wed Dec 12, 2018 6:22 pm
The past few weeks I'm no longer able to connect to my home OpenVPN - using a dynamic DNS server.

NB IP and domains changed for privacy reasons.


Remote Address: mydomain.me.com

No longer works -

If I do a name lookup for mydomain.me.com and put the resulting 105.xxx.xxx.xxx IP as the remote server then it works.

Logs:
2018-12-12 08:07:50: TCP/UDP: Preserving recently used remote address: [AF_INET]148.xxx.xxx.xxx:1194


This remote address is always the same - and does not correspond to the dynamic DNS domain IP.
Are there some options that I need to change? Has something else changed in the Mac IP stack?
Rebooting and flushing DNS caches has no effect.

James

User avatar
Posts: 1869
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Wed Dec 12, 2018 8:35 pm
Hi la442,

Can you please post a copy of your connection's configuration data? You can view the configuration data for your Viscosity connection by opening Viscosity’s Preferences window, holding down the Option key on your keyboard, right-clicking (or control-clicking) on your connection, and selecting “View Configuration Data”.

Please feel free to censor out any sensitive details.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

la442

Posts: 4
Joined: Sun Dec 09, 2018 2:47 am

Post by la442 » Sat Dec 22, 2018 5:21 am
Hi - sorry for delay - forum does not warn me of new posts - have found subscribe setting now.

It occurs on both a Mac and a Windows PC.

I have changed to a static IP rather than a domain name - and then it works - the logs no longer show the "reusing148.xxx" (now it is re-using the 46.xxx domain - which is the IP that is correct).

I have full DNS enabled in the settings.

However, that also means that I don't have the logs that show the problem occurring - there a way to force Viscosity to do a DNS search and do use a specific DNS (say google) to do the search before a connection is established, rather than trying to re-use old?)

Setting windows DNS to use a specific DNS server often runs into problems connecting at hotspots/captive portals, in my experience

James

User avatar
Posts: 1869
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Jan 03, 2019 9:35 pm
I'm afraid I can't offer much in the way of further advice without the configuration data. The "TCP/UDP: Preserving recently used remote address" message isn't normally considered a problem. If you want to make sure OpenVPN doesn't reuse existing IP details you should ensure that the "Persist Local IP" and "Persist Remote IP" options are un-ticked. These can be found under the Options tab when editing your connection in Viscosity.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

la442

Posts: 4
Joined: Sun Dec 09, 2018 2:47 am

Post by la442 » Thu Jan 03, 2019 9:47 pm
Ok- -due to my travels I am unable to test it - as it is a problem that occurs with certain IP providers in internet locations in my home country. Will try to test in 2 weeks.

la442

Posts: 4
Joined: Sun Dec 09, 2018 2:47 am

Post by la442 » Thu Jan 17, 2019 5:36 pm
Unfortunately no change - still have to manually enter the IP address (46.*) as Viscosity seems to always default to some (wrong) 148.* address... Both options mentioned above are unchecked.


2019-01-17 07:27:59: Viscosity Mac 1.7.13 (1478)
2019-01-17 07:27:59: Viscosity OpenVPN Engine Started
2019-01-17 07:27:59: Running on macOS 10.14.2
2019-01-17 07:27:59: ---------
2019-01-17 07:27:59: State changed to Connecting
2019-01-17 07:27:59: Checking reachability status of connection...
2019-01-17 07:27:59: Connection is reachable. Starting connection attempt.
2019-01-17 07:28:00: Unrecognized option or missing or extra parameter(s) in config.conf:27: block-outside-dns (2.4.6)
2019-01-17 07:28:00: OpenVPN 2.4.6 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [MH/RECVDA] [AEAD] built on Nov 23 2018
2019-01-17 07:28:00: library versions: OpenSSL 1.0.2q 20 Nov 2018, LZO 2.10
2019-01-17 07:28:01: TCP/UDP: Preserving recently used remote address: [AF_INET]148.123.xx.xx:1194
2019-01-17 07:28:01: UDP link local (bound): [AF_INET][undef]:0
2019-01-17 07:28:01: UDP link remote: [AF_INET]148.123.xx.xx:1194
6 posts Page 1 of 1