Dual Connection Problem

Got a problem with Viscosity or need help? Ask here!

erochkin

Posts: 1
Joined: Mon Feb 25, 2019 12:08 pm

Post by erochkin » Mon Feb 25, 2019 12:13 pm
I have a problem with the Macintosh Version of Viscosity. I import a connection from Tunnelblick each time that I connect so I have about 40+ connections listed. I set connection 30 to automatically connect when I load Viscosity but I inadvertently set another connection to automatically connect when I load Viscosity. Since it's trying to load two connections at the same time it hangs and "Force Quit" doesn't help because Viscosity doesn't show up in that menu. All I can do is restart. However, even if I delete Viscosity and re-install it, I still have the same dual-connection hang problem. Is there a way that I can clear the connection settings or some other way to avoid this? Thanks.

James

User avatar
Posts: 1892
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Mon Feb 25, 2019 2:04 pm
Hi erochkin,
Is there a way that I can clear the connection settings or some other way to avoid this?
You can delete your connection/s by removing the following folder:
Your Home Folder/Library/Application Support/Viscosity

For more information on how to delete this folder please see:
https://www.sparklabs.com/support/kb/ar ... osity-mac/

That said, we wouldn't consider Viscosity locking up as acceptable or normal behaviour. It's possible one or both of the OpenVPN connections is absolutely hammering out the log output, which Viscosity is struggling to keep up with (if it's using 100% CPU according to Activity Monitor this is likely the cause). However if it otherwise seems to have frozen please let us know and we'll see if we can find out what is going on.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1